Ticket #1085 (closed defect: fixed in core)

Opened 4 years ago

Last modified 15 months ago

GPS do not show satellites or position

Reported by: sferic Owned by: to whom it belongs, don' t know
Priority: major Milestone:
Component: SHR Image Version: SHR-unstable
Keywords: GPS Cc:

Description

With the new image (SHR-T 2010-04-20/21) GPS does not work any longer correctly. GPS seems to work (symbol available), satellites however is not shown. A test with openmoko agpsui did not bring results (run with free view over one hour). Possibly does a connection exist with Ticket#1079 and 1084? I'm gladly ready to supply Debug information ask however in the case for references to the necessary terminal instructions (me are missing still the fundamental knowledge for this). Thanks first for each assistance

Attachments

frameworkd.log.ogpsd-snip Download (1.2 KB) - added by sferic 4 years ago.

Change History

Changed 4 years ago by sferic

comment:1 Changed 4 years ago by sferic

I looked for still another little for possible causes for the error and found the added entry in the log file framworkd.log.

comment:3 Changed 4 years ago by sferic

Thank you for the tip. But it didn't worked for me. I did everything like described and changed fsotdld.conf too. After I started GPS manually I tried to get a satellite-signal for about half an hour, but failed. What can I do else (to get helpful messages)?

comment:4 Changed 4 years ago by texoft2

I have installed new image from scratch. GPS works fine, but only until suspend. Afterwards it won't even get GPS time no matter what (start tangoGPS, go see details).

This may be connected to fact that you have to issue suspend command twice to actually suspend.

comment:5 Changed 4 years ago by elhennig

You should run an upgrade of phonefsod, that helped me to sort suspend problems out.

comment:6 Changed 4 years ago by sferic

Now I found  http://lists.openmoko.org/nabble.html#nabble-td2104833. As Angus Ainslie wrote:

"I changed

start-stop-daemon --start /usr/sbin/fso-gpsd -S

localhost:gpsd -P /var/run/${NAME}.pid
to

start-stop-daemon --start -x /usr/sbin/fso-gpsd -- -S

localhost:gpsd -P /var/run/${NAME}.pid

and it's working now."

it worked for me too. So I think /etc/init.d/fso-gpsd.conf should be updated, or am I wrong?.

comment:7 Changed 4 years ago by sferic

.. but can't stop the process now. So I went back and looking out for another solution ...

comment:8 Changed 4 years ago by sferic

  • Status changed from new to closed
  • Resolution set to upstream

Flashed today the new image SHR-T_2010-04-26. With this, GPS worked again for me. So I change the status of the Ticket to ?upstream? I think. Please correct me, if I am wrong

comment:9 Changed 4 years ago by sferic

... but only, when I manualy restart fso-gpsd:

root@om-gta02 ~ $ /etc/init.d/fso-gpsd restart
Stopping freesmartphone.org gpsd compatibility daemon: stopped process in pidfile '/var/run/fso-gpsd.pid' (pid 1268)
(done)
Starting freesmartphone.org gpsd compatibility daemon: (ok)

Without that the GPS don't come up after a reboot. Strange

comment:10 Changed 4 years ago by sferic

  • Status changed from closed to reopened
  • Resolution upstream deleted

comment:11 Changed 4 years ago by sferic

… but not always. In the meantime I did have installed omgps, that sometimes functioned and sometimes not. But I'm missing now the agps-switch in the menu settings - postion (perhaps omgps has removed this, there the program queries the agps data from u-blox).

If I call settings - position via the terminal, I get the following message with an Python error message, which I already noticed with ticket 1084:

root@om-gta02 ~ $ shr-settings Position shr_gps.Gps shr_gpsinfo.GpsInfo?
SHR Settings
/usr/lib/python2.6/site-packages/dbus/connection.py:242: DeprecationWarning?: object.init() takes no parameters

super(Connection, self).init(*args, kwargs)

DEBUG: creating window: ['Position', , ['shr_gps.Gps', 'shr_gpsinfo.GpsInfo?']]
Launcher loaded in 6.91 sec
Loading module shr_gps.Gps...
Module shr_gps.Gps loaded in 0.52 sec
Loading module shr_gpsinfo.GpsInfo?...
Module shr_gpsinfo.GpsInfo? loaded in 0.44 sec
Page loaded in 0.98 sec

The GPS module seems to be started, but I get a position only very irregularly. Can that be examined by someone, which is been versed with dbus or the Python module?

comment:12 Changed 4 years ago by Heinervdm

  • Milestone changed from MS1 to MS2

comment:13 Changed 4 years ago by jeremy-list

This bug is still present after rolling back to the april 01 testing rootfs image. So either it's older than that image or it's a problem in the kernel and modules.

comment:14 follow-up: ↓ 15 Changed 4 years ago by GarthPS

  • Version changed from SHR-testing to SHR-unstable

I am not sure that SHR is for something here. I think it is perhaps due to a change of kernel (not sure because I think remember that I had this with the 2.6.29 too) or a change in FSO (I am more for this option)

comment:15 in reply to: ↑ 14 Changed 4 years ago by Davide

I'm pretty sure problem is related to 2.6.32 + uboot.

After flashing qi on my FR, I can get a fix after suspend.

comment:16 Changed 4 years ago by Davide

I have just tried 2.6.34.2.
The same sympthoms that with 2.6.32.

With u-boot, gps doesn't work after a reboot.
With qi, yes.

comment:17 Changed 4 years ago by jeremy-list

By the way, does qi also make GSM and/or wifi work? If so, I'll switch back to SHR. Had abandoned the distro because of bugs #1142, #1085, and #1074. And the fact that no-one seemed to be working on a fix.

comment:18 Changed 4 years ago by Davide

Although I don't use FR as my daily phone, GSM seems very stable for me on latest shr-u images.
It resist on suspend/resume cycles, I got no lost calls, messages seems to get in and out with no trouble...

I cannot say anything about wifi, I hardly use it...

Only problem that remains for me (and not a little one) is with uSD. Related to http://trac.shr-project.org/trac/ticket/1143

If I use uSD, I get NSOD and hard lockups.
It makes latest shr-u (2.6.32 kernel) almos useless for me :(
It's a shame, because despite it latest images are fast and stable as no previous one...

comment:19 Changed 4 years ago by Rukk

just to share my part, im trying the SHR-u from 17-Aug on my sd card, GPS dont work automatically (with tangogps), i must turn it on manually, then i get a fix in 1-2min

comment:20 Changed 3 years ago by elisa42

with shrunstable 20110221 and uboot 1.3.2-glamo242_gena2x from nov 3 2010 gps works like a charm.
i'm not sure if different uboot realy makes a difference. just try with new kernel first :)

comment:21 Changed 2 years ago by morphis

  • Milestone MS2 deleted

Milestone MS2 deleted

comment:23 Changed 15 months ago by Thamos0815

  • Status changed from reopened to closed
  • Resolution set to fixed in core
Note: See TracTickets for help on using tickets.