Opened 8 years ago

Last modified 6 years ago

#1101 new defect

nodm always logs in as root

Reported by: jeremy-list Owned by: ainulindale
Priority: critical Milestone: wishlist
Component: SHR Image Version: SHR-testing
Keywords: Cc:

Description

Fortunately I have some time to sort this out but I don't want to leave the country with my main phone UI running as root all the time!
I've tried setting a whole bunch of variables in /etc/init.d/xserver-nodm but no effect other than changing the working directory. Illume still runs as root regardless.

Attachments (1)

xserver-nodm-start-as-user.patch (341 bytes) - added by jasager 8 years ago.
patch to start x as non-root user

Download all attachments as: .zip

Change History (5)

comment:1 follow-up: Changed 8 years ago by Heinervdm

  • Milestone set to wishlist

Changed 8 years ago by jasager

patch to start x as non-root user

comment:2 in reply to: ↑ 1 Changed 8 years ago by jasager

This should try to run X as non-root.
But you will run in a "permission-denied" hell. The way to go would be adding an xserver group and set the needed permissions on some files. I once tried it, but gave up since most application developers just assume they can read and write every file.

'critical' is right, because the more this is stalled, the more work will it be.

comment:3 Changed 8 years ago by jeremy-list

I'd actually figured out something similar after reporting this bug. But I put the su invocation somewhere else so X11 itself is running as root with illume, phoneuid, etc running as regular user.

comment:4 Changed 6 years ago by iwdy23

Note: See TracTickets for help on using tickets.